[gme-users] Need help in registering Java component in GME

Raghu Vamsi Chavali rchavali at purdue.edu
Fri Jun 18 10:08:40 CDT 2010

Hi all,
I am currently facing an issue with Java Interpreters. I was going 
through the list of issues on JIRA 
<http://repo.isis.vanderbilt.edu/JIRA/secure/Administrators.jspa> and 
found a similar one. But the solution suggested there does not help me. 
My problem is as follows.
As per the userguide, I have registered the TestBONComponent and am 
trying to test the same on GME. It results in " Error loading java. 
Cannot find jvm.dll"  error being thrown. My java installation seems to 
be fine as other applications depending on it run just fine.
I browsed through the previous issues list on this site and came across 
the following issue: (http://repo.isis.vanderbilt.edu/JIRA/browse/GME-120)

After registering TestBONComponent, and enabling in GME, clicking Java 
icon results in "Error Loading java. Cannot query jvm.dll path from 
registry". I have tried setting the JavaClassPath to both gme.jar and 
jvm.dll locations, but no combination seems to work. I also added 
jvm.dll to Windows Path, but still get this error.

  The reply to the above issue was the following:

I don't think there's a JIRA issue, but the source has already been fixed.

The problem was the original code for loading the jvm.dll hardcoded in 
1.4 instead of querying the system for the current version. And it 
didn't become apparent until people that did not have any 1.4.x version 
installed tried to run a Java Component. People who had both 1.4 and 1.5 
installed were unable to reproduce the bug.

Please suggest what else could be wrong with my installation./
Raghu Vamsi Chavali
Purdue University
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://list.isis.vanderbilt.edu/pipermail/gme-users/attachments/20100618/ca50fca1/attachment.html 

More information about the gme-users mailing list