[Ace-users] Socket error 0 on send_n with ace Reactor (ACE_SOCK_Stream)

Ron Grosberg ron.grosberg at gmail.com
Sun Jul 8 07:22:23 CDT 2007

I am working with ACE reactor and ACE_SOCK_Stream. normally everything
works fine.
we have one scenario, in which we are working with 2 application, 2
sockets each - one inside the server (sunos 10), and one outside of
the first running application works fine, but the second one cannot
send data through the socket. the return value is 0 (0 bytes sent),
and errno=0. we tried to do several things:
1. replace the ace send_n with a regular send. didn't work
2. getsockopt(fd, SOL_SOCKET, SO_ERROR, (char *)&value, &val_len ) -
to receive the error. got error 0 again....
3. getsockopt(fd, SOL_SOCKET, SO_SNDBUF, (char *)&value, &val_len ) to
receive the maximum size we can send. when the socket works fine, this
works, but after the first send error we get errno 34 - "Result too
large", which i haven't found documentation for anywhere...
4. Resending the data in a loop, we still get error 0, and nothing is

anyone has any IDEA?

More information about the Ace-users mailing list