[Ace-users] Re: [ciao-users] calling Plan_Launcher leads to Execution_Manager coredump

Krishnakumar B kitty at dre.vanderbilt.edu
Thu Jul 12 11:21:48 CDT 2007

Hi Friedhelm,

On Thu, 12 Jul 2007 04:39:55 AM -0500, Friedhelm Wolf wrote:
> Gan,
>>> When the library name is "libCLogger_execd.so", i entered
>> >> "CLogger_execd" as the <location> value.
>> >
>> > Could you please change it to "CLogger_exec" and see if it works better?
>> > Basically, I suggest you follow the same naming rule as what the "Hello"
>> > example does.
> I tried to do that without success. I now have to versions of the
> libraries residing in $ACE_ROOT/lib (the debug version with *d.so naming
> convention, and the release version).  I tried both versions
> <location>CLogger_exec</location>, and <location>CLogger_execd</location>
> without success.

Can you please give the exact list of commands that you used to create
Makefiles?   Are you still using SuSE (from your original PRF) or have you
switched to using Windows?  All talk about *d and DLL et al doesn't make
sense on SuSE.  How did you generate the MPC file for your components?  Did
you use $ACE_ROOT/bin/generate_component_mpc.pl or did you write it by

Given a component Foo, you should have the following libraries under

Windows (Debug)


Windows (Release)


Linux (Both Debug and Release)


If you don't have these libraries, then you have a problem.  Assuming you
do have these libraries, make sure that you enter Foo_exec in the location
field in CoSMIC corresponding to the Foo_Exec ImplementationArtifact.  BTW,
please also make sure that you do File->Check->Check All to check all the
constraints before you generate a deployment plan using CoSMIC.

>> > For example, you can find below tag
>> >
>> >      <location>Receiver_DnC_exec</location>
>> >
>> > appearing in the .cdp file of Hello example. And then you can check what
>> > the name of the library is in your $ACE_ROOT/lib directory. I suspect it
>> > is Receiver_DnC_execd.so, right?
>> Sorry, I meant libReceiver_DnC_execd.so.
> I just built the release version of ACE/TAO/CIAO and then made symbolic
> links for the lib*d.so libraries, which just reference the release
> versions.

Please don't do any of these tricks.  It becomes a nightmare to track down
the problems.  Either keep separate workspaces or use the
$ACE_ROOT/bin/create_ace_build.pl to create multiple build configurations
with the same source tree.

> For my component projects however, I used the "Debug configuration" for
> MPC (using -type make and setting configurations = Debug in
> $ACE_ROOT/MPC/templates/user_makedll.mpt).  But to check if that is a
> problem, I built my components using the "Release configuration" too. And
> the same problem occured.  So I guess, this is not the problem.

Your using -type make to MPC is the problem.  You should use

$ACE_ROOT/bin/mwc.pl -type gnuace <something.mwc>

to build CIAO on Linux.  And don't modify anything under
$ACE_ROOT/MPC/templates unless you know what you are doing.

Hope this helps.
Krishnakumar B <kitty at dre dot vanderbilt dot edu>
Institute for Software Integrated Systems, Dept. of EECS, Vanderbilt University

More information about the Ace-users mailing list