[Ace-users] Re: [tao-users] TAO1.5 notification service is not working in Solaris/CC environment.

Johnny Willemsen jwillemsen at remedy.nl
Mon Jul 16 03:06:46 CDT 2007

Have a look at the code, maybe remove -ORBLogFile and see if you get output
on the console


From: prakash [mailto:prakash.kadam at gmail.com] 
Sent: Monday, July 16, 2007 9:46 AM
To: Johnny Willemsen
Cc: tao-users at cse.wustl.edu
Subject: Re: TAO1.5 notification service is not working in Solaris/CC

Hi Johnny,
  I run notification service as follows

./Naming_Service -ORBDebug -ORBDebugLevel 10 -ORBLogFile naming.log -o
ns.ior &       
./Notify_Service -ORBInitRef NameService=file://ns.ior -ORBDebug
-ORBDebugLevel 10 -ORBLogFile notify.log

  But it didn't create log file.
   I am using Solaris 8 and Sun CC compiler 5.7.

On 7/16/07, Johnny Willemsen <  <mailto:jwillemsen at remedy.nl>
jwillemsen at remedy.nl> wrote: 


We build daily ACE/TAO on Solaris 10 with Sun Forte 11 and don't have any 
problems running the notification service. Try to run the debugger and see
what happens, or add -ORBDebugLevel 10 to the notification service and see
if you get more info what is happening on your system.


Johnny Willemsen
Remedy IT
Postbus 101
2650 AC  Berkel en Rodenrijs
The Netherlands
www.theaceorb.nl / www.remedy.nl

*** Integrated compile and test statistics see
http://scoreboard.theaceorb.nl ***
*** Commercial service and support for ACE/TAO/CIAO             ***
*** See http://www.theaceorb.nl/en/support.html                 ***

<prakash.kadam at gmail.com> wrote in message
news:<  <mailto:1184563999.169510.261610 at i13g2000prf.googlegroups.com>
1184563999.169510.261610 at i13g2000prf.googlegroups.com>...
> Hi All,
>   I am using TAO1.5 version on solaris machine. with Sun CC compiler.
>   Machin details: SunOS ocean 5.8 Generic_117350-35 sun4u sparc 
> SUNW,Ultra-Enterprise
>   C++ (Sun CC) Compiler details : Sun C++ 5.7 2005/01/07
>   I compiled it successfull. Simple Client-Server is working very
> well, but Notification Service doesn't work. 
>   Following are the steps How I run Notification service.
>   step 1: Start the TAO Naming Service
>     $TAO_ROOT/bin/Naming_Service/Naming_Service -o ns.ior
>   step 2: Start the TAO Notification Service 
>     $TAO_ROOT/bin/Notify_Service/Notify_Service -ORBInitRef
> NameService=file://ns.ior
>     Here, it just display message as 'Loading the Cos Notification
> Service..."
>     but doesn't run ORB threads. 
>   But when I compile it with g++ on same machine, and notification
> service works fine.
>   Please help me to run TAO successfully on Solaris machine with Sun
> CC compiler. 
> Thanks
>   - Prakash Kadam.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://list.isis.vanderbilt.edu/pipermail/ace-users/attachments/20070716/9d9a3349/attachment-0001.htm

More information about the Ace-users mailing list