[ace-users] (no subject)

Douglas C. Schmidt schmidt at dre.vanderbilt.edu
Fri Aug 24 07:49:15 CDT 2007

Hi Kesava,

> Could you please guide me for the below 

Thanks very much for your email.  Please make sure to send all
questions related to TAO or ACE to the ACE mailing list or ACE+TAO
newsgroup, rather than to me directly since I travel frequently and
often don't have ready access to email.  See


for more info on how to access these resources.

> I am facing on exit status issue with ACE library . The background of
> the issue is 
> 1) When i run a command like "mount   /dev/sda6   /mnt " . It is
> failing because of some reasons . Now the error code when i seen in
> the terminal is "you don;t have file system " okk ..No probs for me
> ..What i am thinking is if i put "echo $?" i am getting 32 as the
> error from the command shell or from the terminal .

What does this have to do with ACE?

> [Please note i am using Linux as the OS ]

To ensure that we have proper version/platform/compiler information,
please make sure you fill out the appropriate problem report form (PRF),
which is in


or in


in older versions of ACE+TAO.  Make sure to include this information
when asking any questions about ACE+TAO since otherwise we have to
"guess" what version/platform/compiler/options you've using, which is
very error-prone and slows down our responsiveness.  If you don't use
the PRF, therefore, it is less likely that someone from the core
ACE+TAO developer team will be able to answer your question.
Naturally, we encourage and appreciate other members of the ACE+TAO
user community who can respond to questions that they have the answers

> 2)The Issue  i spawn a process uisng ace and tried to execute the
> command and i wait for the process to
> complete(wait(pid,timeout,status) ....Now the status code i am
> expecting is 32 but it is coming as 8192 ...32 is correct because i
> got this from command prompt or from shell .
> 3)Could you please anyone tell me whether the fun i used right or not
> .Or this is a known bug 

Without more info (e.g., small example of what you're doing) it's
impossible to hep.  Please note that the DOC groups at Washington
University, UC Irvine, and Vanderbilt University only provide "best
effort" support for non-sponsors who are using the latest release, as
described in


Therefore, please make sure you are using ACE+TAO+CIAO x.5.10 (i.e.,
ACE 5.5.10, TAO 1.5.10, and CIAO 0.5.10), which you can download from


under the heading: "Latest Beta Kit".  If you need more "predictable"
help or need help for earlier versions of ACE+TAO+CIAO please see


for a list of companies that will provide you with ACE+TAO+CIAO
commercial support.



More information about the Ace-users mailing list