[Ace-users] [ace-users] Building SVN ACE on Mac OS 10.5

Doug McCorkle mccdo at iastate.edu
Tue Nov 6 17:49:46 CST 2007

On Nov 6, 2007, at 3:43 PM, Doug McCorkle wrote:

> On Nov 6, 2007, at 11:09 AM, Doug McCorkle wrote:
>> On Nov 6, 2007, at 7:52 AM, J.T. Conklin wrote:
>>> Hi Doug,
>>> Doug McCorkle <mccdo at iastate.edu> writes:
>>>>> One thing I'd check is whether ACE_wrappers/ace/Signal.h is being
>>>>> included for <signal.h>.  I believe I ran into this problem in the
>>>>> past, and fixed it by manually modifying the Makefile.am after MPC
>>>>> generation.  I suspect it was inadvertently lost.   
>>>>> Unfortunately, I
>>>>> have no idea what I did.  It may have been a "DEFAULT_INCLUDES="  
>>>>> in
>>>>> ACE_wrappers/ace/Makefile.am.
>>>> Yes. That is the problem. To debug this there is a define:
>>>> This then showed the problem clearly. I am unable to find where
>>>> this:
>>>> -I../../ACE_wrappers/ace
>>>> is being added to compile line in Makefile.am.
>>> It's not being added in Makefile.am, it's being added by autoconf
>>> when
>>> Makefile.in is generated from Makefile.am.
>>> I've looked in past releases, and it turns out I remembered
>>> correctly.
>>> Adding DEFAULT_INCLUDES= to ACE_wrappers/ace/Makefile.am should be
>>> all
>>> that's needed.
>>> Can you add it at the same place CLEANFILES =, lib_LTLIBRARIES =,
>>> etc. are now and let me know how it goes?
>> I understand now. I misunderstood your previous email. I will put  
>> this
>> in and hopefully that makes things work.
> So, that fixed the problem with ACE compiling which is great. The only
> thing I am not sure of now is how to create a patch to correct the
> problem at the MPC level so that the Makefile.am file is correct from
> the start. Any suggestions on that front?
> I will clean up my changes for the m4 and configure.ac file and submit
> a patch for the first problem.

When I tried to move things to the m4 file as you suggested I  
encountered problems. I get these compile errors when I run the  
bootstrap command:

Putting files in AC_CONFIG_AUX_DIR, `../aux_config'.
Putting files in AC_CONFIG_AUX_DIR, `aux_config'.
configure.ac:286: error: possibly undefined macro: AC_DEFINE
       If this token and others are legitimate, please use  
       See the Autoconf documentation.
autoreconf: /usr/bin/autoconf failed with exit status: 1

Attached is the patch that I am working on.


-------------- next part --------------
A non-text attachment was scrubbed...
Name: FD_ISSET.patch
Type: application/octet-stream
Size: 1843 bytes
Desc: not available
Url : http://list.isis.vanderbilt.edu/pipermail/ace-users/attachments/20071106/1d3c8a3f/attachment-0001.obj 
-------------- next part --------------

More information about the Ace-users mailing list