[gme-users] GME ActiveX components

Zoltan Molnar zolmol at isis.vanderbilt.edu
Fri Mar 3 11:18:43 CST 2006

Hi Paul,

I tried a .Net based interpreter showing a Form with the ObjectInspector
component on it, and it worked if I set the MgaObject property to a
Collection (!) of MgaObjects. So the name might be misleading: instead
of one object, a collection is expected.

For some reason (or because the COM-NET interop) the 
MgaObjects mycoll = new MgaObjectsClass(); 
line is not compiling, but I could get a MgaObjects collection by
getting the RootFolder's ChildObjects property.

IMgaTerritory terr;
project.CreateTerritory( null, out terr, null);
transactiontype_enum mod = transactiontype_enum.TRANSACTION_GENERAL;
project.BeginTransaction( terr, mod);

MgaFolder rf = project.RootFolder;
MgaObjects childObjs = rf.ChildObjects;


// later use this childObjs value 
axObjectInspector2.MgaProject = project;
axObjectInspector2.MgaObject = childObjs;

Br, Zoli

> -----Original Message-----
> From: gme-users-bounces at list.isis.vanderbilt.edu 
> [mailto:gme-users-bounces at list.isis.vanderbilt.edu] On Behalf 
> Of Paul Foster
> Sent: Thursday, March 02, 2006 1:59 PM
> To: gme-users
> Subject: [gme-users] GME ActiveX components
> Anyone aware of known bugs in the ActiveX components like:
> - COM exceptions when setting the MgaObject property on the 
> object inspector
> - Unable to get the Console to register properly
> I'm trying to host these ActiveX components as part of a 
> Visual Studio .Net Add-In. Which brings up the question - 
> anyone try this?
> Paul Foster
> _______________________________________________
> gme-users mailing list
> gme-users at list.isis.vanderbilt.edu
> http://list.isis.vanderbilt.edu/mailman/listinfo/gme-users

More information about the gme-users mailing list